Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Copied Transaction ZCS02 not working...

Former Member
0 Kudos
271

Hi,

I want to create a copy of transaction CS02. But this is a function Group (CSDI).. After all, i copy the Function Group with all Function Modules. Also create a t.code ZCS02 through SE93 (copy program SAPMC29S also).

But, when i m executing the ZCS02 transaction, it's not working..means not responding.

Please tell me what would be the problem..

Regards,

5 REPLIES 5

former_member195383
Active Contributor
0 Kudos
115

This may be authorisation issue. Please check wheather you have proper authorisation for the same.

Former Member
0 Kudos
115

Hi,

Copy the function group from SE80.

Thanks

Sudheer

ThomasZloch
Active Contributor
0 Kudos
115

Don't copy complex standard transactions. Getting the copy to run is one nightmare (e.g. some hidden table settings might expect the original object names), as you are finding out right now, inserting SAP notes for the standard transaction into your copy will be another one later on. A mix of standard and Z-includes can be even worse, once the next upgrade comes along.

I'm interested in your motivation, why are you copying the transaction?

Thomas

0 Kudos
115

Thanks for ur reply,

We have some issues with the users, so don;t want to give the CS02 transaction to them...so i want to create a new Z transaction for user.

But after copy the function group from SE80, it is not working properly...

Please suggest..

regards......

Edited by: Prince Kumar on Jun 4, 2009 3:20 PM

0 Kudos
115

>

> We have some issues with the users, so don;t want to give the CS02 transaction to them...so i want to create a new Z transaction for user.

>

I think you can restrict that by using the Roles and authorization, did you try that?

Regards

Karthik D