Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

BAPI_ACC_DOCUMENT_POST is not working in VLPOD Tcode

kabil_g
Active Participant
0 Kudos

Hi Frds,

Bit urgent , When i checked in debugging its updating & not working at time save without break point......

BAPI_ACC_DOCUMENT_POST  is working in DEV Server when i moved to Qas server its not working . Pls he...

My piece of code is given below at the time of save callin these codes........

     CALL FUNCTION 'BAPI_ACC_DOCUMENT_POST'

        EXPORTING

          documentheader = ls_header

        IMPORTING

          obj_type       = lv_obj_type

          obj_key        = lv_obj_key

          obj_sys        = lv_obj_sys

        TABLES

          accountgl      = lt_item

          currencyamount = lt_item_curr

          return         = lt_return.

    READ TABLE lt_return INTO ls_return WITH KEY type = gc_s.

      IF sy-subrc = 0.

        WAIT UP TO 2 SECONDS.

        CALL FUNCTION 'BAPI_TRANSACTION_COMMIT'

         EXPORTING

           WAIT          = abap_true.

       ENDIF.

   REFRESH : lt_item,

             lt_item_curr,

             lt_return.

ENDAT.

1 ACCEPTED SOLUTION

pothireddygowtham
Discoverer
0 Kudos

Hi Kabil ,

  Try to add return to BAPI_TRANSACTION_COMMIT and see if you are getting any error captured over there.

Regards,

Gowtham.

2 REPLIES 2

pothireddygowtham
Discoverer
0 Kudos

Hi Kabil ,

  Try to add return to BAPI_TRANSACTION_COMMIT and see if you are getting any error captured over there.

Regards,

Gowtham.

0 Kudos

Hi Gowtham,

Thanks for your reply . some logic is failed before bapi called so its not called bapi... Closing the thread.

Regards,

Kabil.G