Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Access problem on HR

Former Member
0 Kudos
213

Hello All,

I have a strange situation.

System : HR

Support package : latest

10 Users have authorization to view master record of all users with the present roles assigned their User Master Record.

1 user has the same roles assigned but not able to see records for any employee.

I have tested on the test box by creating an access similar to production for the user and there he is able to see the employee records.

Your advise will be helpful.

Vidyar

1 ACCEPTED SOLUTION

Former Member
0 Kudos
105

Hi Vidyar,

Please check the following things for the user having access issue:

1. Is the user id tagged to IT0105 for any Pernr? If yes, then please remove it.

2. Check if any structural profile is assigned to the user in table T77UA. Use T-Code OOSB and search for the user id there. It might be possible if you are using Position driven structural auth and because the user id is tagged to a Pernr, a structural profile got assigned to it due to execution of RHBAUS* programs.

Let me know if the above points happened. I will let you know how to fix it then.

Thanks

Debmalya

7 REPLIES 7

Former Member
0 Kudos
106

Hi Vidyar,

Please check the following things for the user having access issue:

1. Is the user id tagged to IT0105 for any Pernr? If yes, then please remove it.

2. Check if any structural profile is assigned to the user in table T77UA. Use T-Code OOSB and search for the user id there. It might be possible if you are using Position driven structural auth and because the user id is tagged to a Pernr, a structural profile got assigned to it due to execution of RHBAUS* programs.

Let me know if the above points happened. I will let you know how to fix it then.

Thanks

Debmalya

0 Kudos
105

Debmalya,

1. Hope I did correct as I am new to HR ( I did PA30 put in the user lat name and in the "infotype" put in 0105 and subtype 0001 )

then I deleted the user Id from the field : ID/number under communication 0105 )

2. I checkedunder OOSB , 5 auth.profiles are assigned to the user ID.

Vidyar

0 Kudos
105

Hi Vidyar,

Great! How do you assign structural auth to users? Is it Position driven (Assign PD Profile through IT1017 in a Position) or directly assign Structural auth to an user through OOSB?

In the second case, just delete the entries for the corresponding user id in T77UA table using OOSB. Given that you have already removed IT0105 Subtype:0001 tagging from The Pernr.

If it's a Position driven assignment, please do the following steps:

1. Reassign the user id to IT0105 to the same Pernr as before using PA30.

2. Select the associated Position and through PO13 or PP01, delete all entries contained in IT1017 (PD Profiles).

3. Now Run RHPROFL0 (For the Position) followed by RHBAUS02 ( for the user id) followed by RHBAUS01 and at last RHBAUS00. This should remove all entries for the user from T77UA, will refresh T77UU and remove entries from INDX table.

Please validate in OOSB if the entries still exists for the user.

4. Now remove the IT0105 Subtype:0001 tagging for the user id from the Pernr.

5. You can now add back the PD Profiles in the same position through PP01 or PO13.

Let me if this works.

Thanks Debmalya

0 Kudos
105

Debmalya,

Thank you for the advise, I will update you as soon as I complete and it works.

Vidyar.

0 Kudos
105

Debmalya,

Thank you ,

It worked.

It was a position based assignement.

I really appritiate your help.

I have one more challenge now, but I will post another thread, if you can advise it will be helpful, I need to do the other way round for few users.

Vidyar.

0 Kudos
105

I tried assigning points but it shows as

unassigned.

I will try after few minutes.

Vidyar

0 Kudos
105

Thanks,

I will look forward to your new issue.