Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

ABAP Trial - Error 7.52 SP04 VMWare 14 and Credential Guard - Other options?

Sandra_Rossi
Active Contributor
0 Kudos

Hello,

I have installed VMWare 14 latest patch on my Windows 2010 - 20H1 build - according to the ABAP 7.52 SP04 VMWare procedure at c86f9218-687d-0010-87a3-c30de2ffd8ff.pdf (sap.com) given by AS ABAP 7.52 SP04, Developer Edition: Concise Installation Guide | SAP Blogs.

I run the Virtual Machine for the first time:

but I immediately get this error:

https://www.vmware.com/go/turnoff_CG_DG"VMware Workstation and Device/Credential Guard are not compatible" error in VMware Workstation on W...

As I have Windows 2010 -20H1 build-, it says I must install at least VMWare 15.5.6.

But the ABAP 7.52 VMWare guide says "Do not install version 15.0 yet. There is currently an issue with version 15 and some versions of Windows (independent of AS ABAP)".

I previously had an issue with 15.5.7, VMWare produced at some time a corrupted virtual disk that I couldn't repair, and hanged completely after some time using the ABAP trial. I also realized late that I had a 100% used file system, so of course maybe it was the sole reason, but it was too late to extend it. EDIT: I realize that 100% is "normal" as shown in the ABAP 7.52 VMWare guide:

It's the 3rd time I'm about to reinstall VMWare (I didn't do an image after SAP installation because of size, but I think I'd better have done it). I'm wondering whether the latest VMWare Workstation 17 version could solve the issues I had, so I'd like to know your opinion.

  • Do you run one VMWare 15+ version for months without any issue? Which one? Did you have any issue specific to any VMWare version? Any advice.
  • My laptop is managed by my company, so I can't do much about Credential Guard (as far as I understand). Do you have the same configuration, did you find a solution?
  • In the coming weeks or months, I should get a brand new laptop with Windows 11, do you know if it works better? (also, 32 GB RAM instead of 16 GB)
  • I'm afraid to install ABAP 1909 because Docker requires 170 GB, my laptop will be left 60 GB on total 512 GB, any performance experience at your side?

Thank you!

Sandra

EDIT: in 2021, I also used Oracle VirtualBox but had a license issue about its Extension Pack at my company although it was not installed (!?), it's why I switched to VMWare.

4 REPLIES 4

abo
Active Contributor

Not much of an answer on the Windows-specific issues, but I sidestepped the issue completely by installing 7.52SP04 in Virtualbox (using OpenSUSE) and I am running Docker natively, on the same Debian Linux host. The company laptop is just a client, no big deal.

Back in my previous role, I had quite good experience with Vmware Workstation Player, but we had full admin rights so whatever problem I encountered was solved directly by me with a bit of research.

Anyway, regarding the performance, if the host has more than the recommended minimum amount of RAM the docker image will run quite smoothly even on not-so-modern hw. With 32GB I can run both the VM and the docker container just fine and the system is still pretty snappy overall.

Sandra_Rossi
Active Contributor
0 Kudos

Back in 2021, I was using VirtualBox but my company identified it incorrectly as being Oracle VirtualBox Extension Pack and had to pay for it. After many useless protestations, I gave up and switched to VMWare.

I have the "admin rights" (run as admin, install software) but not all.

I'm still having 16 GB RAM, but my next laptop will be with 32 GB.

I guess I'll wait for the new laptop to install Docker. I'll try VMWare 17 for now.

abo
Active Contributor

docker is a bit more efficient on Linux since it is able to just let kernel calls pass through, whereas on Windows it must first run its own kernel in a VM. IIRC vmware too is only free for non-commercial use, so that's something to keep in mind.

Sandra_Rossi
Active Contributor
0 Kudos

I have installed VMWare Workstation 17. It complained about a hypervisor being installed (Hyper-V/Credential Guard - See PS below), requested to either uninstall the hypervisor or install Windows Hypervisor Platform (WHP).

I selected the checkbox to install WHP. It seemed to work. I could install OpenSUSE 15.3.3 as explained in the ABAP 7.52 SP04 VMWare guide.

TO BE UPDATED...

PS: hypervisor detected - Hyper-V. Way to check indicated at Disable Hyper-V to run virtualization software - Windows Client | Microsoft Learn: