Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

ABAP communication layer is not configured properly.

marcosandrade
Participant
28,637

Hello Developers,

I`m an ABAP developer and would like to use ABAP in Eclipse. I have installed Eclipse Kepler 4.3 in Windows 7 64 bit along with the component from the website  https://tools.hana.ondemand.com/#abap

after installed the ADT component and UI5 I got the issue with communication Layer attached.

I have installed the JCO from SAP website and followed the configuration.

I have gone through all the procedures below.

1. Microsoft VC runtime is missing: as per information ontools.hana.ondemand.com/#abap you have to download and install it from: x86 orx64

2. Not proper JAVA is installed: JAVA JRE 1.6 or higher is needed, download it from http://java.com/en/download/manual.jsp. I choose to install JAVA Platform SE 7 U67 version 7.0.670.1.


3. As per Note “2041195 - Eclipse does not identify operating system correctly” I set settings in Eclipse’s eclipse.ini file. Add following line:

-Dorg.osgi.framework.os.name=win32

Into -vmargs section of file.


does anyone knows what else should be done?


Kind Regards

1 ACCEPTED SOLUTION

Thilo
Explorer
5,486

Hi Frank,

with the current ADT version sapjco3.dll was updated, VS2010 does not work any more, you need VS2013. Download the newer Microsoft VC Runtime DLLs from here

https://support.microsoft.com/de-ch/help/4032938/update-for-visual-c-2013-redistributable-package

Kind regards

Thilo

45 REPLIES 45

Former Member
5,257

Hello,

mentioned steps are correct. After you perform them, try to run Eclipse with attribute "-clean". Just make new shortcut and to the end of the link add "-clean". I had same problem and it somehow remembered the previous settings.

Kind regards

0 Kudos
5,256

Hello Kamil,

I have added the "-clean" but still did not work.

see the java.init.

is there a sapjco 721,215??

Kind Regards

0 Kudos
5,256

Well, you have made same mistake as me

In the manual is written  -Dorg.osgi.framework.os.name=win32 so why you are you adding -Dorg.osgi.framework.os.name=win64?

It is because the program must think you have 32bit system.

0 Kudos
5,256

Kamil is right, the required value is "win32".

Just for clarification: It's not to run Eclipse under the assumption it runs on a 32 Bit system. It's just a value that can be mentioned as the the name of the operating system that is known to Eclipse. For historic reasons "win32" is a valid value. You could also use "Windows7", but when we faced this issue the first time, the Eclipse version that was supported at this time, did not know "Windows7". So we recommend to set "win32" as os.name.

Two of the related bugs reported to Eclipse:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=281075

https://bugs.eclipse.org/bugs/show_bug.cgi?id=423970


Regards, Felix

0 Kudos
5,256

Well, I had missunderstood the reason. Thank you for clarification, Felix.

0 Kudos
5,256

Hello Guys,

thank you for your help. I think we are almost there.

I have changed the name but unfortunately it did not work. So I assume the problem is not there, there must be another place I did not manage properly.

have a look how it is now.

The DLL is also installed. See below.

I have installed everything for 64bit, JRE, JDK, Eclipse Kepler and JCO3.

for JCO I have the following file name

sapjco3-NTAMD64-3.0.11

any idea?

0 Kudos
5,256

Is the error exactly the same? Have you tried one more time that clean? I think so, I am just asking to be sure...

0 Kudos
5,257

Another issue which it might be - check the place C:\Windows\System32. If there is sapjco3.dll library, delete it (or better just move it somewhere else). Then run it with -clean again.

0 Kudos
5,257

Hello,

I have ran the eclipse shortcut with the -clean and without the clean. Still got the same issue.

I did not find the sapjco3.dll libray in the mentioned path.

In the following argument I found out that SAP Jco 3.0.11 requires JDK/JRE 5, 6 or 7. I`m running 8 at the moment. Might be the issue???

https://websmp209.sap-ag.de/~form/handler?_APP=00200682500000002672&_EVENT=DISPLAY&_SCENARIO=0110003...

The package of the SAP JCo 3.0.11 includes the software as well as documentation and examples. SAP JCo 3.0.11 requires a JDK/JRE 5, 6 or 7.Note: Starting with JCo 3.0.6 the packaging had to be adjusted. Please extract the nested archive variant from the downloaded archive first. In case you have installation instructions from some other component they will refer to the nested archive.

The archives for Windows and Mac OS X of SAP JCo are shipped as a zip file embedded in a zip file. The archives for the Unix versions of SAP JCo are shipped as a tgz file file embedded in a zip file.


Below the installation I have done in the eclipse side.



0 Kudos
5,256

Well, I have to say that I also spotted your version 8 in the very beginning. But I am not sure if it could be the issue. In my opinion it could be, because not all newest versions of whatever you want are not always compatible with something "older". If you don't mind, try to "downgrade" or you can wait for another expert to get envolved.

0 Kudos
5,256

Kamil,

what are the version of JDK and JRE you are using?

0 Kudos
5,256

Well, good question and I have to say I do not know now I will update this post when I am back home (lets say in 4 hours), because I have to check it on my personal computer.

Update: So I have this versions installed:

0 Kudos
5,256

That's a valid point. Eclipse tries to use the JCO installed on your machine, while it brings it's own. Is the JCO version you have installed in your user folder populated in the PATH variable? We had this constellation in at least one case and saw a similar error message.

Please make sure when you change PATH, that Eclipse works with the changed one.

Regards, Felix

0 Kudos
5,256

Hello Felix,

I have done that before, and eclipse is pointing out to the JCO path that I have defined in PATH system variable.

I will downgrade the JRE version and see what happens. I will let you know.

0 Kudos
5,256

Hello Kamil,

I have downgraded JDK to 7 and still the same issue. I was using SAPGUI 7.40 and uninstalled and it did not work.

which eclipse are you using Kepler or Luna?

Kegards

0 Kudos
5,256

I am using Kepler and SAP GUI 7.40 also.

This is interesting case. But as Felix also adviced, I think your system must somehow using different version of the library. Maybe try to search whole computer for the library sapjco3.dll.

0 Kudos
5,256

Hello Guys,

the solution in my case was to remove the System variable PATH and it worked. I found out another post when the guy had to remove the system variable and it worked.

I don`t know why but after applying the changes with win32 and "-clean" attribute it started working.

I hope my next post should be related to using the ADT instead of installation

thank you guys for your support.

Kind Regards

frankmueller9
Participant
5,256

Hello,

I know that this thread is old, but I have the same issue now during the update of the current ATD Version. It works before but now I get the following error. Do you have any additional ideas?

Best regards

Frank

Thilo
Explorer
5,487

Hi Frank,

with the current ADT version sapjco3.dll was updated, VS2010 does not work any more, you need VS2013. Download the newer Microsoft VC Runtime DLLs from here

https://support.microsoft.com/de-ch/help/4032938/update-for-visual-c-2013-redistributable-package

Kind regards

Thilo

5,256

Thanks @Thilo Kloper. you saved my day....

0 Kudos
5,256

Super! Danke Thilo 🙂

0 Kudos
5,256

It resolved my problem 🙂

0 Kudos
5,256

Tks Thilo, You just helped me as well !

0 Kudos
5,256

Just faced same issue in 2022.

Thank you!

0 Kudos
5,256

I had same issue and this helped me.

0 Kudos
5,256

Thanks it worked.

0 Kudos
5,256

please help me out

0 Kudos
5,256

please help me out

ysoethoff
Product and Topic Expert
Product and Topic Expert
0 Kudos
5,256

Hello Kriuthika,

based on the screenshot it looks like you are using an old version of Eclipse & ADT:

The error message is referring to Mircosoft Runtime DLLs VS2010.
As stated by Thilo Klopfer, the latest ADT releases need VS2013 since several years ago.

Therefore start with a fresh installation of Eclipse & ADT incl. using a fresh workspace. Please install the necessary and correct version of Microsoft VC++ Runtime. You should be able to find all the information "How-To" and links to the necessary versions here: https://tools.hana.ondemand.com/#abap

You can also find further information about the necessary Microsoft Components for Windows in our ADT installation guide in the prerequisites section - https://help.sap.com/doc/2e9cf4a457d84c7a81f33d8c3fdd9694/LATEST/en-US/inst_guide_abap_development_t...

Kind regards,
Yannic

0 Kudos
5,256

Hi sir,

I've tried to get the new version but I didn't can you please provide me with eclipse and toolkit's new version link that will run sapui5 fiori plugin please

5,256

Close to one decade and this issue is still persistent and this solution is still a valid one.

Thanks,

Sijin

CarstenKasper
Active Contributor
5,256

thilo.klopfer2 Thank you very much! It took me the whole evening yesterday to install and uninstall Java, Eclipse, ADT, VC2010 and SAPJCo. With your hint my installation was up and running without any further problems 🙂

rubin_luke3
Participant
5,256

thilo.klopfer2 Thank you very much!. It worked for me as well

Eclipse Version: 2019-06 (4.12.0)

bruno_alves
Explorer
0 Kudos
5,256

thilo.klopfer2 thanks a lot. Also working for me.

Eclipse Version 2019-06(4.12.0) running on Windows 10.

former_member676808
Discoverer
0 Kudos
5,256

Thanks a lot. Solved the problem.

Mariusz
Explorer
0 Kudos
5,256

thilo.klopfer2 thanks a lot.

vinay_udekar
Explorer
0 Kudos
5,256

thilo.klopfer2 Thank you very much!. It worked for me as well

Eclipse IDE for Java Developers

Version: 2020-09 (4.17.0)
Build id: 20200910-1200

former_member451655
Active Participant
0 Kudos
5,256

thilo.klopfer2 thanks a lot.

TD
Explorer
0 Kudos
5,256

thilo.klopfer2 thanks a lot