cancel
Showing results for 
Search instead for 
Did you mean: 

error while trying to assign a role via CUP in Portal

Former Member
0 Kudos
80

Hello Experts,

I am trying to create a request to assign a role in EP via CUP ( 5.3)

EP Connector is working fine as I have imported Portal roles etc

SPML service is working fine

I have done the mapping in the Provisioning tab for Portal system

logonname in portal is email address of an employee

So the I have done the following mapping

AC Field Application field

email addres-Stndard logonname

And I have the following error while trying to create a request which I grabbed form the log

ERROR Exception during EJB call, Ignoring and trying Webservice Call

LinkageError: loader constraints violated when linking com/virsa/cc/xsys/webservices/dto/WSRAInputParamDTO class

ERROR com.virsa.ae.core.BOException: Exception from the service : Invalid System

com.virsa.ae.core.BOException: Exception from the service : Invalid System

ERROR : BO Exception in Save request

Any suggestions would be really appreciated

Regards

Kev

Accepted Solutions (0)

Answers (2)

Answers (2)

hkaur
Advisor
Advisor
0 Kudos

Hello Kevin,

The error is not related to the Rules and the request should get created even if there are no rules. Can you check the Field Mapping? Also, what is teh User Details data source that you are using? Can you please check that system also ?

Harleen

Former Member
0 Kudos

Hi Harleen,

The user Datasource is LDAP ( MS-AD) and field mapping is configured alright

Regards

Kev

Former Member
0 Kudos

Kevin,

I was able to replicate your issue and there is a setting in the CUP that you have to disable, Goto the config tab in the CUP and select NO for the "Risk Analysis On Request Submission " under risk analysis.

Issue here is you did not create a connector for your EP in the RAR, I believe you have the above mentioned parameter to yes and so when you are submitting a request CUP is trying to do the risk analysis but RAR was not able to find any System, so it is thowing an error.

You can resolve this issue in two ways, one is to create a connector in RAR or the other is to disable the setting in the CUP.

Hope this helps.

Naveen

Former Member
0 Kudos

Hi Naveen,

thanks for your reply , I had this as NO right from the start.

It was to do with initiator , i have resolved this issue , facing other now ... I will have to re check my field mapping & paramters passed in EP connector.

Thanks

Kev

hkaur
Advisor
Advisor
0 Kudos

Hi Kevin,

Have you installed the EP RTA on your EP system?

Harleen

SAP GRC RIG

Former Member
0 Kudos

Hello Harleen,

I can confirm that the RTA is installed for EP .

But I was wondering has it got anything do with Risk analysis ? I mean there are no rules for EP in RAR

does this matter ( I have made risk analysis NOT mandatory)

well none of the Error's are related to Rules not being configured etc,but just a thought...

Regards

Kev

Former Member
0 Kudos

Kevin,

Looks like there might be some thing wrong with the EP connector. Could you test the EP connector you created and see whether the test is successful??

- Naveen

Former Member
0 Kudos

Naveen ,

The connector is prefectly fine, I have tested it and conenction was succesful , and also have imported roles , so that is proof enough that connector is spot on.

Regards

Kev