<?xml version="1.0" encoding="UTF-8"?>
<rss xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#" xmlns:taxo="http://purl.org/rss/1.0/modules/taxonomy/" version="2.0">
  <channel>
    <title>Question Re: Error 500: Cannot process an HTTP request to servlet [lama_api] in [lama-api] web application in Technology Q&amp;A</title>
    <link>https://community.sap.com/t5/technology-q-a/error-500-cannot-process-an-http-request-to-servlet-lama-api-in-lama-api/qaa-p/12781177#M4798596</link>
    <description>&lt;P&gt;Hi Naeem,&lt;/P&gt;&lt;P&gt;first of all: happy new year &lt;span class="lia-unicode-emoji" title=":slightly_smiling_face:"&gt;🙂&lt;/span&gt; Sorry for the delay - sickness and holiday season here at the moment...&lt;/P&gt;&lt;P&gt;And yep, it's still an issue...&lt;/P&gt;&lt;P&gt;But why should we restart NetWeaver after applying SPs? I mean, it has just been restarted by SUM. Well, I trust in SUM that it does everything necessary when the patches are applied &lt;span class="lia-unicode-emoji" title=":winking_face:"&gt;😉&lt;/span&gt; but to be save I double checked the SUM logs and I see no issues - deployment without problems and after that system start and restart services were performed without errors or warnings. I just want to understand why you think another restart would change something..?&lt;/P&gt;&lt;P&gt;Best regards, Marie&lt;/P&gt;</description>
    <pubDate>Tue, 02 Jan 2024 10:14:28 GMT</pubDate>
    <dc:creator>marie_renneke</dc:creator>
    <dc:date>2024-01-02T10:14:28Z</dc:date>
    <item>
      <title>Error 500: Cannot process an HTTP request to servlet [lama_api] in [lama-api] web application</title>
      <link>https://community.sap.com/t5/technology-q-a/error-500-cannot-process-an-http-request-to-servlet-lama-api-in-lama-api/qaq-p/12781175</link>
      <description>&lt;P&gt;Dear Community,&lt;/P&gt;
  &lt;P&gt;(probably) since applying SP29 for the Landscape Management components (this Monday) we're facing a problem with getting the activity status via REST API with &lt;A href="https://allxlmci.oediv.lan:57101/lama-api/activities/2387278?query=fields=items%28activityNumber,status%29"&gt;activities/&amp;lt;activityno&amp;gt;?query=fields=items(activityNumber,status)&lt;/A&gt;&lt;/P&gt;
  &lt;P&gt;It worked fine until now. Suddenly we're facing "500 Internal Server Error" responses and find the following error in LaMas java logs: "Cannot process an HTTP request to servlet [lama_api] in [lama-api] web application. For more details on the problem please check traces searching by logId: C000C2AFA09DB07600000005000052A6"&lt;/P&gt;
  &lt;P&gt;The only trace / log entry we find with this logId is the quoted one and nothing related during the time period it occured.&lt;/P&gt;
  &lt;P&gt;And as is always the case - the colleague who wrote the script is not available anymore...&lt;/P&gt;
  &lt;P&gt;Do you have any idea what changed / what's wrong here out of a sudden? The only thing I see in &lt;A href="https://me.sap.com/notes/3316859/E"&gt;SAP note 3316859&lt;/A&gt; that might refer to this is "The REST API returns an error when invalid query parameters are sent." - but how come this is suddenly invalid when it worked all the time before ... and I don't see any difference in the API reference... &lt;/P&gt;
  &lt;P&gt;Hopefully you experts can help us here.&lt;/P&gt;
  &lt;P&gt;Thanks &amp;amp; regards, Marie&lt;/P&gt;</description>
      <pubDate>Thu, 14 Dec 2023 14:41:08 GMT</pubDate>
      <guid>https://community.sap.com/t5/technology-q-a/error-500-cannot-process-an-http-request-to-servlet-lama-api-in-lama-api/qaq-p/12781175</guid>
      <dc:creator>marie_renneke</dc:creator>
      <dc:date>2023-12-14T14:41:08Z</dc:date>
    </item>
    <item>
      <title>Re: Error 500: Cannot process an HTTP request to servlet [lama_api] in [lama-api] web application</title>
      <link>https://community.sap.com/t5/technology-q-a/error-500-cannot-process-an-http-request-to-servlet-lama-api-in-lama-api/qaa-p/12781176#M4798595</link>
      <description>&lt;P&gt;Hello,&lt;/P&gt;&lt;P&gt;Is this still an issue? Could it be that you forgot to restart Neweaver after applying the new SP level ?&lt;/P&gt;&lt;P&gt;Cheers,&lt;/P&gt;&lt;P&gt;Naeem&lt;/P&gt;</description>
      <pubDate>Wed, 20 Dec 2023 20:08:05 GMT</pubDate>
      <guid>https://community.sap.com/t5/technology-q-a/error-500-cannot-process-an-http-request-to-servlet-lama-api-in-lama-api/qaa-p/12781176#M4798595</guid>
      <dc:creator>naeem_maqsud</dc:creator>
      <dc:date>2023-12-20T20:08:05Z</dc:date>
    </item>
    <item>
      <title>Re: Error 500: Cannot process an HTTP request to servlet [lama_api] in [lama-api] web application</title>
      <link>https://community.sap.com/t5/technology-q-a/error-500-cannot-process-an-http-request-to-servlet-lama-api-in-lama-api/qaa-p/12781177#M4798596</link>
      <description>&lt;P&gt;Hi Naeem,&lt;/P&gt;&lt;P&gt;first of all: happy new year &lt;span class="lia-unicode-emoji" title=":slightly_smiling_face:"&gt;🙂&lt;/span&gt; Sorry for the delay - sickness and holiday season here at the moment...&lt;/P&gt;&lt;P&gt;And yep, it's still an issue...&lt;/P&gt;&lt;P&gt;But why should we restart NetWeaver after applying SPs? I mean, it has just been restarted by SUM. Well, I trust in SUM that it does everything necessary when the patches are applied &lt;span class="lia-unicode-emoji" title=":winking_face:"&gt;😉&lt;/span&gt; but to be save I double checked the SUM logs and I see no issues - deployment without problems and after that system start and restart services were performed without errors or warnings. I just want to understand why you think another restart would change something..?&lt;/P&gt;&lt;P&gt;Best regards, Marie&lt;/P&gt;</description>
      <pubDate>Tue, 02 Jan 2024 10:14:28 GMT</pubDate>
      <guid>https://community.sap.com/t5/technology-q-a/error-500-cannot-process-an-http-request-to-servlet-lama-api-in-lama-api/qaa-p/12781177#M4798596</guid>
      <dc:creator>marie_renneke</dc:creator>
      <dc:date>2024-01-02T10:14:28Z</dc:date>
    </item>
    <item>
      <title>Re: Error 500: Cannot process an HTTP request to servlet [lama_api] in [lama-api] web application</title>
      <link>https://community.sap.com/t5/technology-q-a/error-500-cannot-process-an-http-request-to-servlet-lama-api-in-lama-api/qaa-p/12781178#M4798597</link>
      <description>&lt;P&gt;Hello again,&lt;/P&gt;&lt;P&gt;problem "solved" - or more precisely: workaround implemented. Seems the Lama API just doesn't respond as it used to.&lt;/P&gt;&lt;P&gt;But first of all thank you, Naeem. We didn't get any helpful error message - until we restarted the whole system. After that we received a much more informative error message:&lt;/P&gt;&lt;PRE&gt;&lt;CODE&gt;{"status":400,"code":"INVALID_REQUEST","message":"Received unknown query parameters: [query]. REST Method GET /activities/2390601 allows the following query parameters: [embed, fields]","severity":"ERROR"}&amp;lt;br&amp;gt;&lt;/CODE&gt;&lt;/PRE&gt;&lt;P&gt;Hence using "query" in a query seems to be deprecated, we changed the query to look like this: &lt;A rel="nofollow" href="https://allxlmci.oediv.lan:57101/lama-api/activities/2387278?query=fields=items%28activityNumber,status%29"&gt;activities/&amp;lt;activityno&amp;gt;?fields=items(activityNumber,status)&lt;/A&gt; ... which, as far as we know, should've worked... but didn't - the response is empty: {}&lt;/P&gt;&lt;P&gt;So we changed our script to simply get all information via &lt;A rel="nofollow" href="https://allxlmci.oediv.lan:57101/lama-api/activities/2387278?query=fields=items%28activityNumber,status%29"&gt;activities/&amp;lt;activityno&amp;gt;&lt;/A&gt; and cut out the activity status then. Not the most elegant way, but it works for us - for this one script...&lt;/P&gt;&lt;P&gt;We see this behaviour of the API in different queries, like systems, hosts etc. - especially when executed for a single item (system/host/activity...). When executed as a mass query it seems to work.&lt;/P&gt;&lt;P&gt;Anyone else having trouble with this since SP29?&lt;/P&gt;&lt;P&gt;Thanks &amp;amp; cheers, Marie&lt;/P&gt;</description>
      <pubDate>Wed, 03 Jan 2024 13:45:00 GMT</pubDate>
      <guid>https://community.sap.com/t5/technology-q-a/error-500-cannot-process-an-http-request-to-servlet-lama-api-in-lama-api/qaa-p/12781178#M4798597</guid>
      <dc:creator>marie_renneke</dc:creator>
      <dc:date>2024-01-03T13:45:00Z</dc:date>
    </item>
    <item>
      <title>Re: Error 500: Cannot process an HTTP request to servlet [lama_api] in [lama-api] web application</title>
      <link>https://community.sap.com/t5/technology-q-a/error-500-cannot-process-an-http-request-to-servlet-lama-api-in-lama-api/qaa-p/12781179#M4798598</link>
      <description>&lt;P&gt;Dear all,&lt;/P&gt;&lt;P&gt;problem solved completely: we found out the correct syntax through trial and error - so this (hopefully) works now for all Lama APIs - here are two examples:&lt;/P&gt;&lt;P&gt;activities/&lt;EM&gt;&amp;lt;act.No&amp;gt;&lt;/EM&gt;?fields=activityNumber,status&lt;/P&gt;&lt;P&gt;systems/SystemID.&lt;EM&gt;&amp;lt;SID&amp;gt;&lt;/EM&gt;.SystemHost.&lt;EM&gt;&amp;lt;Host&amp;gt;&lt;/EM&gt;?fields=name,systemUUID&lt;BR /&gt;&lt;/P&gt;&lt;P&gt;Maybe this might help someone else.&lt;/P&gt;&lt;P&gt;Cheers, Marie&lt;/P&gt;</description>
      <pubDate>Mon, 15 Jan 2024 09:23:02 GMT</pubDate>
      <guid>https://community.sap.com/t5/technology-q-a/error-500-cannot-process-an-http-request-to-servlet-lama-api-in-lama-api/qaa-p/12781179#M4798598</guid>
      <dc:creator>marie_renneke</dc:creator>
      <dc:date>2024-01-15T09:23:02Z</dc:date>
    </item>
  </channel>
</rss>

